10110 - Light, more lightTime limit: 3.000 seconds
The ProblemThere is man named "mabu" for switching on-off light in our University. He switches on-off the lights in a corridor. Every bulb has its own toggle switch. That is, if it is pressed then the bulb turns on. Another press will turn it off. To save power consumption (or may be he is mad or something else) he does a peculiar thing. If in a corridor there is `n' bulbs, he walks along the corridor back and forth `n' times and in i'th walk he toggles only the switches whose serial is divisable by i. He does not press any switch when coming back to his initial position. A i'th walk is defined as going down the corridor (while doing the peculiar thing) and coming back again. Now you have to determine what is the final condition of the last bulb. Is it on or off?The InputThe input will be an integer indicating the n'th bulb in a corridor. Which is less then or equals 2^32-1. A zero indicates the end of input. You should not process this input.The OutputOutput "yes" if the light is on otherwise "no" , in a single line.Sample Input3
6241
8191
0
Sample Outputno
yes
no
by-
Sadi Khan
Suman Mahbub
01-04-2001
|
_______________________________________________
solution:
#include<stdio.h>
#include<math.h>
int main()
{
long n, a, b;
while(scanf("%lld", &n)==1)
{
if(n==0)
break;
a= sqrt(n);
b=a*a;
if(b==n)
printf("yes\n");
else
printf("no\n");
};
return 0;
}
No comments:
Post a Comment