Thursday 25 July 2013

UVA sloved: problem number: 10055 - Hashmat the Brave Warrior

question:
Problem A
Hashmat the brave warrior
Input: standard input

Output: standard output

Hashmat is a brave warrior who with his group of young soldiers moves from one place to another to fight against his opponents. Before fighting he just calculates one thing, the difference between his soldier number and the opponent's soldier number. From this difference he decides whether to fight or not. Hashmat's soldier number is never greater than his opponent.

Input
The input contains two integer numbers in every line. These two numbers in each line denotes the number of soldiers in Hashmat's army and his opponent's army or vice versa. The input numbers are not greater than 2^32. Input is terminated by End of File.

Output
 For each line of input, print the difference of number of soldiers between Hashmat's army and his opponent's army. Each output should be in seperate line.

Sample Input:
10 12
10 14
100 200

Sample Output:
2
4
100
   ____________________________________________________________________


answer:
#include<cstdio>
using namespace std;

int main()

{
long long h,a;
while(scanf("%lld%lld",&h,&a)==2)
{
long long data=h-a;
if(data<0)
data=data*-1;
printf("%lld\n",data);
}
return 0;

}


**use the code only for practice purpose. don't ruin your programming career copy-pasting this.

No comments:

Post a Comment